Support Phone Outage
Incident Report for Menufy
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 12:21 CDT
Monitoring
Our Talk service partner has confirmed that basic call functionality has been restored. Thank you for your patience during the investigation.
Posted Apr 22, 2024 - 11:49 CDT
Identified
Our Talk service provider has acknowledged that there is an ongoing issue with inbound and outbound calls, including silence on calls and difficulty connecting new calls.
Posted Apr 22, 2024 - 11:32 CDT
Investigating
We are currently experiencing an outage with our phone vendor were we are unable to hear our merchants on support calls. Our vendor is actively addressing this issue and will will update this accordingly.
Posted Apr 22, 2024 - 11:06 CDT